package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\Q[SQLITE_CONSTRAINT_UNIQUE] \E(.*?)\Q (UNIQUE constraint failed\E`)
var str = `org.sqlite.SQLiteException: [SQLITE_CONSTRAINT_UNIQUE] A UNIQUE constraint failed (UNIQUE constraint failed Items.Name)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}