re = /\Q[SQLITE_CONSTRAINT_UNIQUE] \E(.*?)\Q (UNIQUE constraint failed\E/
str = 'org.sqlite.SQLiteException: [SQLITE_CONSTRAINT_UNIQUE] A UNIQUE constraint failed (UNIQUE constraint failed Items.Name)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end