import Foundation
let pattern = #"\Q[SQLITE_CONSTRAINT_UNIQUE] \E(.*?)\Q (UNIQUE constraint failed\E"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"org.sqlite.SQLiteException: [SQLITE_CONSTRAINT_UNIQUE] A UNIQUE constraint failed (UNIQUE constraint failed Items.Name)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}