#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/a/b(?!.*/Dont Want This/).*/tag$"
Local $sString = "/a/b/c/d/Dont Want This/tag" & @CRLF & _
"/a/b/c/d/e/.../x/Dont Want This/random stuff/tag" & @CRLF & _
"/a/b/c/d/Want This/tag" & @CRLF & _
"/a/b/c/d/e/.../x/Want This/random stuff/tag" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")