using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/a/b(?!.*/Dont Want This/).*/tag$";
string input = @"/a/b/c/d/Dont Want This/tag
/a/b/c/d/e/.../x/Dont Want This/random stuff/tag
/a/b/c/d/Want This/tag
/a/b/c/d/e/.../x/Want This/random stuff/tag
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}