import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/a/b(?!.*/Dont Want This/).*/tag$";
final String string = "/a/b/c/d/Dont Want This/tag\n"
+ "/a/b/c/d/e/.../x/Dont Want This/random stuff/tag\n"
+ "/a/b/c/d/Want This/tag\n"
+ "/a/b/c/d/e/.../x/Want This/random stuff/tag\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}