use strict;
my $str = '/a/b/c/d/Dont Want This/tag
/a/b/c/d/e/.../x/Dont Want This/random stuff/tag
/a/b/c/d/Want This/tag
/a/b/c/d/e/.../x/Want This/random stuff/tag
';
my $regex = qr/^/a/b(?!.*/Dont Want This/).*/tag$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}