#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*:\s*"
Local $sString = "key1 : value1" & @CRLF & _
"key2:value2" & @CRLF & _
"key3: value3"
Local $sSubst = " : "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)