import Foundation
let pattern = #"\s*:\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
key1 : value1
key2:value2
key3: value3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" : "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)