re = /\s*:\s*/m
str = 'key1 : value1
key2:value2
key3: value3'
subst = ' : '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result