$re = '/\s*:\s*/m';
$str = 'key1 : value1
key2:value2
key3: value3';
$subst = " : ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;