using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*href=""(\S*)""";
string input = @"<a href=""http://www.any-web_address.com"">
<a href=""http://142.12.64.71:8083"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}