// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*href="(\S*)""#).unwrap();
let string = "<a href=\"http://www.any-web_address.com\">
<a href=\"http://142.12.64.71:8083\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}