$re = '/.*href="(\S*)"/';
$str = '<a href="http://www.any-web_address.com">
<a href="http://142.12.64.71:8083">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);