const regex = /.*href="(\S*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*href="(\\S*)"', 'g')
const str = `<a href="http://www.any-web_address.com">
<a href="http://142.12.64.71:8083">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}