#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:([^\:]*)\:\/\/)?(?:([^\:\@]*)(?:\:([^\@]*))?\@)?(?:([^\/\:]*)\.(?=[^\.\/\:]*\.[^\.\/\:]*))?([^\.\/\:]*)(?:\.([^\/\.\:]*))?(?:\:([0-9]*))?(\/[^\?#]*(?=.*?\/)\/)?([^\?#]*)?(?:\?([^#]*))?(?:#(.*))?"
Local $sString = "http://robin:mofakham@regex101.com/something/else?data=param#anchor" & @CRLF & _
"https://www.regex101.com/something/else?data=param#anchor" & @CRLF & _
"http://www.regex101.com/something/else?data=param#anchor" & @CRLF & _
"https://regex101.com/something/else?data=param#anchor" & @CRLF & _
"http://regex101.com/something/else?data=param#anchor" & @CRLF & _
"regex101.com/something/else?data=param#anchor" & @CRLF & _
"www.regex101.com/something/else?data=param#anchor" & @CRLF & _
"https://www.regex101.com/" & @CRLF & _
"http://www.regex101.com/" & @CRLF & _
"https://regex101.com/" & @CRLF & _
"http://regex101.com/" & @CRLF & _
"regex101.com/" & @CRLF & _
"www.regex101.com/" & @CRLF & _
"https://www.regex101.com" & @CRLF & _
"http://www.regex101.com" & @CRLF & _
"https://regex101.com" & @CRLF & _
"http://regex101.com" & @CRLF & _
"regex101.com" & @CRLF & _
"www.regex101.com" & @CRLF & _
"https://www.regex101.co.uk/something/else?data=param#anchor" & @CRLF & _
"http://www.regex101.co.uk/something/else?data=param#anchor" & @CRLF & _
"https://regex101.co.uk/something/else?data=param#anchor" & @CRLF & _
"http://regex101.co.uk/something/else?data=param#anchor" & @CRLF & _
"regex101.co.uk/something/else?data=param#anchor" & @CRLF & _
"www.regex101.co.uk/something/else?data=param#anchor" & @CRLF & _
"https://www.regex101.co.uk/" & @CRLF & _
"http://www.regex101.co.uk/" & @CRLF & _
"https://regex101.co.uk/" & @CRLF & _
"http://regex101.co.uk/" & @CRLF & _
"regex101.co.uk/" & @CRLF & _
"www.regex101.co.uk/" & @CRLF & _
"https://www.regex101.co.uk" & @CRLF & _
"http://www.regex101.co.uk" & @CRLF & _
"https://regex101.co.uk" & @CRLF & _
"http://regex101.co.uk" & @CRLF & _
"regex101.co.uk" & @CRLF & _
"www.regex101.co.uk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")