const regex = /(?:([^\:]*)\:\/\/)?(?:([^\:\@]*)(?:\:([^\@]*))?\@)?(?:([^\/\:]*)\.(?=[^\.\/\:]*\.[^\.\/\:]*))?([^\.\/\:]*)(?:\.([^\/\.\:]*))?(?:\:([0-9]*))?(\/[^\?#]*(?=.*?\/)\/)?([^\?#]*)?(?:\?([^#]*))?(?:#(.*))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([^\\:]*)\\:\\\/\\\/)?(?:([^\\:\\@]*)(?:\\:([^\\@]*))?\\@)?(?:([^\\\/\\:]*)\\.(?=[^\\.\\\/\\:]*\\.[^\\.\\\/\\:]*))?([^\\.\\\/\\:]*)(?:\\.([^\\\/\\.\\:]*))?(?:\\:([0-9]*))?(\\\/[^\\?#]*(?=.*?\\\/)\\\/)?([^\\?#]*)?(?:\\?([^#]*))?(?:#(.*))?', 'gm')
const str = `http://robin:mofakham@regex101.com/something/else?data=param#anchor
https://www.regex101.com/something/else?data=param#anchor
http://www.regex101.com/something/else?data=param#anchor
https://regex101.com/something/else?data=param#anchor
http://regex101.com/something/else?data=param#anchor
regex101.com/something/else?data=param#anchor
www.regex101.com/something/else?data=param#anchor
https://www.regex101.com/
http://www.regex101.com/
https://regex101.com/
http://regex101.com/
regex101.com/
www.regex101.com/
https://www.regex101.com
http://www.regex101.com
https://regex101.com
http://regex101.com
regex101.com
www.regex101.com
https://www.regex101.co.uk/something/else?data=param#anchor
http://www.regex101.co.uk/something/else?data=param#anchor
https://regex101.co.uk/something/else?data=param#anchor
http://regex101.co.uk/something/else?data=param#anchor
regex101.co.uk/something/else?data=param#anchor
www.regex101.co.uk/something/else?data=param#anchor
https://www.regex101.co.uk/
http://www.regex101.co.uk/
https://regex101.co.uk/
http://regex101.co.uk/
regex101.co.uk/
www.regex101.co.uk/
https://www.regex101.co.uk
http://www.regex101.co.uk
https://regex101.co.uk
http://regex101.co.uk
regex101.co.uk
www.regex101.co.uk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}