re = /(?:([^\:]*)\:\/\/)?(?:([^\:\@]*)(?:\:([^\@]*))?\@)?(?:([^\/\:]*)\.(?=[^\.\/\:]*\.[^\.\/\:]*))?([^\.\/\:]*)(?:\.([^\/\.\:]*))?(?:\:([0-9]*))?(\/[^\?#]*(?=.*?\/)\/)?([^\?#]*)?(?:\?([^#]*))?(?:#(.*))?/m
str = 'http://robin:mofakham@regex101.com/something/else?data=param#anchor
https://www.regex101.com/something/else?data=param#anchor
http://www.regex101.com/something/else?data=param#anchor
https://regex101.com/something/else?data=param#anchor
http://regex101.com/something/else?data=param#anchor
regex101.com/something/else?data=param#anchor
www.regex101.com/something/else?data=param#anchor
https://www.regex101.com/
http://www.regex101.com/
https://regex101.com/
http://regex101.com/
regex101.com/
www.regex101.com/
https://www.regex101.com
http://www.regex101.com
https://regex101.com
http://regex101.com
regex101.com
www.regex101.com
https://www.regex101.co.uk/something/else?data=param#anchor
http://www.regex101.co.uk/something/else?data=param#anchor
https://regex101.co.uk/something/else?data=param#anchor
http://regex101.co.uk/something/else?data=param#anchor
regex101.co.uk/something/else?data=param#anchor
www.regex101.co.uk/something/else?data=param#anchor
https://www.regex101.co.uk/
http://www.regex101.co.uk/
https://regex101.co.uk/
http://regex101.co.uk/
regex101.co.uk/
www.regex101.co.uk/
https://www.regex101.co.uk
http://www.regex101.co.uk
https://regex101.co.uk
http://regex101.co.uk
regex101.co.uk
www.regex101.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end