import re
regex = re.compile(r"(?:([^\:]*)\:\/\/)?(?:([^\:\@]*)(?:\:([^\@]*))?\@)?(?:([^\/\:]*)\.(?=[^\.\/\:]*\.[^\.\/\:]*))?([^\.\/\:]*)(?:\.([^\/\.\:]*))?(?:\:([0-9]*))?(\/[^\?#]*(?=.*?\/)\/)?([^\?#]*)?(?:\?([^#]*))?(?:#(.*))?", flags=re.MULTILINE)
test_str = ("http://robin:mofakham@regex101.com/something/else?data=param#anchor\n"
"https://www.regex101.com/something/else?data=param#anchor\n"
"http://www.regex101.com/something/else?data=param#anchor\n"
"https://regex101.com/something/else?data=param#anchor\n"
"http://regex101.com/something/else?data=param#anchor\n"
"regex101.com/something/else?data=param#anchor\n"
"www.regex101.com/something/else?data=param#anchor\n"
"https://www.regex101.com/\n"
"http://www.regex101.com/\n"
"https://regex101.com/\n"
"http://regex101.com/\n"
"regex101.com/\n"
"www.regex101.com/\n"
"https://www.regex101.com\n"
"http://www.regex101.com\n"
"https://regex101.com\n"
"http://regex101.com\n"
"regex101.com\n"
"www.regex101.com\n"
"https://www.regex101.co.uk/something/else?data=param#anchor\n"
"http://www.regex101.co.uk/something/else?data=param#anchor\n"
"https://regex101.co.uk/something/else?data=param#anchor\n"
"http://regex101.co.uk/something/else?data=param#anchor\n"
"regex101.co.uk/something/else?data=param#anchor\n"
"www.regex101.co.uk/something/else?data=param#anchor\n"
"https://www.regex101.co.uk/\n"
"http://www.regex101.co.uk/\n"
"https://regex101.co.uk/\n"
"http://regex101.co.uk/\n"
"regex101.co.uk/\n"
"www.regex101.co.uk/\n"
"https://www.regex101.co.uk\n"
"http://www.regex101.co.uk\n"
"https://regex101.co.uk\n"
"http://regex101.co.uk\n"
"regex101.co.uk\n"
"www.regex101.co.uk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")