#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z]+|[A-Za-z]+\s[A-Za-z]+)$"
Local $sString = "Some String" & @CRLF & _
"some string" & @CRLF & _
"some" & @CRLF & _
"string" & @CRLF & _
"strin1" & @CRLF & _
"string string2" & @CRLF & _
"M3" & @CRLF & _
"M n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")