re = /^([A-Za-z]+|[A-Za-z]+\s[A-Za-z]+)$/m
str = 'Some String
some string
some
string
strin1
string string2
M3
M n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end