package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z]+|[A-Za-z]+\s[A-Za-z]+)$`)
var str = `Some String
some string
some
string
strin1
string string2
M3
M n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}