import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[client <HOST>;] user .*; not found: \\/phpmyadmin\\/|[client <HOST>;] user root: authentication failure for \"\\/phpmyadmin\\/\":";
final String string = "Jun 20 00:06:51 mail dovecot: auth-worker(12786): sql(marchwinska@womczest.edu.pl,14.99.33.34,<cmoeqCXFQ6kOYyEi>): Password mismatch";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}