import re
regex = re.compile(r"[client <HOST>;] user .*; not found: \/phpmyadmin\/|[client <HOST>;] user root: authentication failure for \"\/phpmyadmin\/\":")
test_str = "Jun 20 00:06:51 mail dovecot: auth-worker(12786): sql(marchwinska@womczest.edu.pl,14.99.33.34,<cmoeqCXFQ6kOYyEi>): Password mismatch"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")