package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9]|[12][0-9]|3[01])$`)
var str = `0
1
2
3
4
5
6
7
8
9
10
11
19
20
21
29
30
31
32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}