// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-9]|[12][0-9]|3[01])$").unwrap();
let string = "0
1
2
3
4
5
6
7
8
9
10
11
19
20
21
29
30
31
32";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}