const regex = /^(?:[0-9]|[12][0-9]|3[01])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9]|[12][0-9]|3[01])$', 'gm')
const str = `0
1
2
3
4
5
6
7
8
9
10
11
19
20
21
29
30
31
32`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}