$re = '/(CN=)(.*?)(?<!\\\\),.*/mi';
$str = 'CN=Lastname\\, FirstName,OU=org,OU=Unit,DC=Domain,DC=com
CN=1234567,OU=org,OU=Unit,DC=Domain,DC=com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);