import re
regex = re.compile(r"(CN=)(.*?)(?<!\\),.*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("CN=Lastname\\, FirstName,OU=org,OU=Unit,DC=Domain,DC=com\n"
"CN=1234567,OU=org,OU=Unit,DC=Domain,DC=com\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")