re = /(CN=)(.*?)(?<!\\),.*/mi
str = 'CN=Lastname\\, FirstName,OU=org,OU=Unit,DC=Domain,DC=com
CN=1234567,OU=org,OU=Unit,DC=Domain,DC=com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end