# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"//img;t' <<< "\"http://ichart.finance.yahoo.com/table.csv? s=XLK &a= 2 &b= 24 &c= 2014 &e= 04 &d= 07 &f= 2014\""