// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)\""#).unwrap();
let string = "\"http://ichart.finance.yahoo.com/table.csv? s=XLK &a= 2 &b= 24 &c= 2014 &e= 04 &d= 07 &f= 2014\"";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}