const regex = /\"/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"', 'img')
const str = `"http://ichart.finance.yahoo.com/table.csv? s=XLK &a= 2 &b= 24 &c= 2014 &e= 04 &d= 07 &f= 2014"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);