$re = '/\"/im';
$str = '"http://ichart.finance.yahoo.com/table.csv? s=XLK &a= 2 &b= 24 &c= 2014 &e= 04 &d= 07 &f= 2014"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;