import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?)://((www\\.)?example\\.com)/([a-z0-9]{12})/((?:[\\w-]+|\\.(?!html?$))+)";
final String string = "https://example.com/4scdhh0gifzd/my-file.txt.html\n"
+ "https://example.com/4scdhh0gifzd/my-file.txt.htm\n"
+ "https://example.com/4scdhh0gifzd/my-file.txt\n\n"
+ "https://example.com/4scdhh0gifzd/my-file.txt.html\n"
+ "Нужно получить my-file.txt вместо my-file.txt.html\n\n"
+ "https://example.com/4scdhh0gifzd/my-file.txt.html.html\n"
+ "Нужно получить my-file.txt.html вместо my-file.txt.html.html\n\n"
+ "https://example.com/4scdhh0gifzd/my-file.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}