use strict;
my $str = 'https://example.com/4scdhh0gifzd/my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.htm
https://example.com/4scdhh0gifzd/my-file.txt
https://example.com/4scdhh0gifzd/my-file.txt.html
Нужно получить my-file.txt вместо my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.html.html
Нужно получить my-file.txt.html вместо my-file.txt.html.html
https://example.com/4scdhh0gifzd/my-file.html
';
my $regex = qr~(https?)://((www\.)?example\.com)/([a-z0-9]{12})/((?:[\w-]+|\.(?!html?$))+)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}