import Foundation
let pattern = #"(https?)://((www\.)?example\.com)/([a-z0-9]{12})/((?:[\w-]+|\.(?!html?$))+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://example.com/4scdhh0gifzd/my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.htm
https://example.com/4scdhh0gifzd/my-file.txt
https://example.com/4scdhh0gifzd/my-file.txt.html
Нужно получить my-file.txt вместо my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.html.html
Нужно получить my-file.txt.html вместо my-file.txt.html.html
https://example.com/4scdhh0gifzd/my-file.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)