re = /(https?):\/\/((www\.)?example\.com)\/([a-z0-9]{12})\/((?:[\w-]+|\.(?!html?$))+)/m
str = 'https://example.com/4scdhh0gifzd/my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.htm
https://example.com/4scdhh0gifzd/my-file.txt
https://example.com/4scdhh0gifzd/my-file.txt.html
Нужно получить my-file.txt вместо my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.html.html
Нужно получить my-file.txt.html вместо my-file.txt.html.html
https://example.com/4scdhh0gifzd/my-file.html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end