#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!0(\.0{1,3})?$)[0-4](\.\d{1,3})?|5(\.0{1,3})?)$"
Local $sString = "5.000" & @CRLF & _
"4.891" & @CRLF & _
"0.001" & @CRLF & _
"0.9" & @CRLF & _
"2.1" & @CRLF & _
"3" & @CRLF & _
"0.111" & @CRLF & _
"0.000" & @CRLF & _
"0" & @CRLF & _
"5.101" & @CRLF & _
"6" & @CRLF & _
"4.1011"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")