const regex = /^((?!0(\.0{1,3})?$)[0-4](\.\d{1,3})?|5(\.0{1,3})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!0(\\.0{1,3})?$)[0-4](\\.\\d{1,3})?|5(\\.0{1,3})?)$', 'gm')
const str = `5.000
4.891
0.001
0.9
2.1
3
0.111
0.000
0
5.101
6
4.1011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}