$re = '/^((?!0(\.0{1,3})?$)[0-4](\.\d{1,3})?|5(\.0{1,3})?)$/m';
$str = '5.000
4.891
0.001
0.9
2.1
3
0.111
0.000
0
5.101
6
4.1011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);