import re
regex = re.compile(r"^((?!0(\.0{1,3})?$)[0-4](\.\d{1,3})?|5(\.0{1,3})?)$", flags=re.MULTILINE)
test_str = ("5.000\n"
"4.891\n"
"0.001\n"
"0.9\n"
"2.1\n"
"3\n"
"0.111\n"
"0.000\n"
"0\n"
"5.101\n"
"6\n"
"4.1011")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")