using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*([^\*]|\*[^\/])*\*\/";
string input = @"pre comment /* inside comment */ and ouside comment /* inside /* comment */ and this is outside --> */
You can even group several lines /*
As in this comment
that spans several lines
*/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}