re = /\/\*([^\*]|\*[^\/])*\*\//m
str = 'pre comment /* inside comment */ and ouside comment /* inside /* comment */ and this is outside --> */
You can even group several lines /*
As in this comment
that spans several lines
*/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end