package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*([^\*]|\*[^\/])*\*\/`)
var str = `pre comment /* inside comment */ and ouside comment /* inside /* comment */ and this is outside --> */
You can even group several lines /*
As in this comment
that spans several lines
*/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}