import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\S*[A-Z])(?=\\S*[a-z])(?=\\S*[0-9])|(?=\\S*[A-Z])(?=\\S*[a-z])(?=\\S*[~!@#])";
final String string = "lowerUPPER123\n"
+ "123UPPERlower\n"
+ "!lower!UPPER!\n"
+ "lower123!!!\n\n"
+ "123lower\n"
+ "!UPPER!!\n\n"
+ "Hello! If you have Windows10, you might get wrong matches.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}