re = /(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[0-9])|(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[~!@#])/m
str = 'lowerUPPER123
123UPPERlower
!lower!UPPER!
lower123!!!
123lower
!UPPER!!
Hello! If you have Windows10, you might get wrong matches.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end