import re
regex = re.compile(r"(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[0-9])|(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[~!@#])", flags=re.MULTILINE)
test_str = ("lowerUPPER123\n"
"123UPPERlower\n"
"!lower!UPPER!\n"
"lower123!!!\n\n"
"123lower\n"
"!UPPER!!\n\n"
"Hello! If you have Windows10, you might get wrong matches.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")