$re = '/(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[0-9])|(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[~!@#])/m';
$str = 'lowerUPPER123
123UPPERlower
!lower!UPPER!
lower123!!!
123lower
!UPPER!!
Hello! If you have Windows10, you might get wrong matches.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);