using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![A-Za-z0-9])[A-G][b#]?(?=(?:m(?:(?:aj|in)(?:or)?)?)?(?![A-Za-z]))";
string input = @"sample_F_one_shot.wav
sample_oneshot_F#maj.wav
sample_Ab_one_shot.wav
[F]
(A#)
F#maj
C1
F#2
Gm
Diginoiz_-MVP4_OneShot_G#Maj-_Bass
FROM THIS LINE
VEDH Synth Cut 028 GMaj7-9.wav
VEDH Synth Cut 046 FMaj7.wav";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}